Why do I need Flash? – Ustream will only use HTML5 if it thinks you are viewing from a mobile device (iPad, iPhone, etc…). If you are watching in a browser, and you do not have Flash (believe me, we understand), install a User-Agent switcher plugin. This plugin will allow your browser to behave like a smartphone or tablet, and Ustream will present the HTML5 version of the player. Feel free to reach out to any of us on the show if you have questions!